Drupal 8 commerce composer依赖关系图

Submitted by admin on Fri, 12/27/2019 - 17:10

commerce kickstart目前看起来不支持drupal 8,取而代之的是drupalcommerce/demo-project。  按照官方的版本库来推测,默认drupal commerce项目,应该都是从drupalcommerce/project-base开始创建。

drupalcommerce/demo-project => composer-project
    composer/installers
    cweagans/composer-patches
    drupal/console
    drupal/core
    drupal/core-composer-scaffold
    drupalcommerce/demo_commerce
    oomphinc/composer-installers-extender
    webflo/drupal-finder
    webmozart/path-util
    zaporylie/composer-drupal-optimizations
	drupalcommerce/demo_commerce => drupal-profile
		drupal/admin_toolbar
	    drupal/belgrade
	    drupal/commerce
	    drupal/commerce_cart_api
	    drupal/commerce_cart_flyout
	    drupal/commerce_demo => drupal-module,提供demo内容
	    drupal/swiftmailer
	    drupal/token

drupalcommerce/project-base => composer-project
	omposer/installers
    cweagans/composer-patches
    drupal/console
    drupal/core
    drupal/core-composer-scaffold
    drupal/commerce
    drupal/search_api
    drupal/swiftmailer
    drupal/token
    drupalcommerce/commerce_base => drupala-profile
		drupal/commerce
    	drupal/admin_toolbar
    	drupal/swiftmailer
    oomphinc/composer-installers-extender
    webflo/drupal-finder
    webmozart/path-util
    zaporylie/composer-drupal-optimizations